
 

100 WordPress interview questions and answers 

 

Basic WordPress Interview Questions 
1. What is WordPress? 

 WordPress is an open-source CMS that allows users to create and manage 
websites easily. It is written in PHP and uses a MySQL database. 
 

2. What are the key features of WordPress? 
 

○ Easy to use 
○ Customizable themes & plugins 
○ SEO-friendly 
○ Media management 
○ Mobile responsiveness 

3. What are the differences between WordPress.org and WordPress.com? 
 

○ WordPress.org: Self-hosted, full control, requires web hosting. 
○ WordPress.com: Hosted, limited customization, free with restrictions. 

4. How do you install WordPress? 
 

○ Download from wordpress.org 
○ Upload to a server via FTP 
○ Create a database 
○ Run the installation script (wp-admin/install.php) 

5. What are WordPress themes? 
 Themes control the look and feel of a WordPress website. 
 

6. How do you install a theme in WordPress? 
 

○ Dashboard → Appearance → Themes → Add New → Install → Activate 
7. What are WordPress plugins? 

 Plugins extend WordPress functionality without modifying core files. 
 

8. How do you install a plugin in WordPress? 
 

○ Dashboard → Plugins → Add New → Search & Install 
9. What are WordPress widgets? 

 Widgets are small modules that can be added to sidebars, footers, and widget-ready 
areas. 
 

10. How do you create a menu in WordPress? 
 

○ Dashboard → Appearance → Menus → Create New → Add Pages 

https://wordpress.org/


 

 

Intermediate WordPress Interview Questions 
11. What is a child theme in WordPress? 

 A child theme inherits the parent theme’s features but allows customization without 
modifying the original files. 
 

12. How do you create a child theme? 
 

○ Create a new folder in /wp-content/themes/ 
○ Add a style.css file with a header specifying the parent theme 
○ Add a functions.php file 

13. What is the difference between posts and pages in WordPress? 
 

○ Posts: Time-sensitive, listed in reverse chronological order. 
○ Pages: Static content, no date association. 

14. What are custom post types? 
 Custom post types allow you to create new content types beyond posts and pages. 
 

How do you create a custom post type in WordPress? 
 
 function custom_post_type() { 
    register_post_type('portfolio', 
        array( 
            'labels' => array('name' => __('Portfolio')), 
            'public' => true, 
            'has_archive' => true, 
            'supports' => array('title', 'editor', 'thumbnail') 
        ) 
    ); 
} 
add_action('init', 'custom_post_type'); 

15.  
16. What are taxonomies in WordPress? 

 Taxonomies help categorize content. Default ones are categories and tags. 
 

17. What is a shortcode in WordPress? 
 A shortcode is a small snippet wrapped in square brackets ([shortcode]) that 
executes custom functions. 
 

How do you create a shortcode? 
 
 function my_shortcode() { 



 

    return "Hello, this is a custom shortcode!"; 
} 
add_shortcode('greeting', 'my_shortcode'); 

18.  
19. How do you change the WordPress login URL? 

 Use a plugin like "WPS Hide Login" or modify .htaccess. 
 

20. What is wp-config.php? 
 It is the configuration file containing database connection settings, security keys, and 
other essential configurations. 
 

 

Advanced WordPress Interview Questions 
21. What is the WordPress REST API? 

 The REST API allows developers to interact with WordPress using JSON. 
 

22. How do you optimize a WordPress website for speed? 
 

○ Use caching plugins (WP Rocket, W3 Total Cache) 
○ Optimize images (TinyPNG, Smush) 
○ Use a Content Delivery Network (CDN) 

23. How do you secure a WordPress website? 
 

○ Keep WordPress, themes, and plugins updated 
○ Use strong passwords 
○ Limit login attempts 

24. What is a nonce in WordPress? 
 A nonce (Number Used Once) is a security token used to prevent CSRF attacks. 
 

25. What is the difference between get_template_part() and 
locate_template()? 
 

○ get_template_part(): Loads template files. 
○ locate_template(): Searches multiple directories for a template. 

26. What are the WordPress database tables? 
 

○ wp_posts (Stores posts, pages, and custom post types) 
○ wp_users (Stores user information) 
○ wp_options (Stores site-wide settings) 

27.How do you disable WordPress revisions? 
 Add this line to wp-config.php: 



 

 
 php 
CopyEdit 
define('WP_POST_REVISIONS', false); 
 
28.How do you reset the WordPress admin password via phpMyAdmin? 
 Run this SQL query: 
 
 sql 
CopyEdit 
UPDATE wp_users SET user_pass = MD5('newpassword') WHERE user_login 
= 'admin'; 
 
29.What is the difference between is_page() and is_single()? 
 

● is_page(): Checks if the page being viewed is a specific page. 
● is_single(): Checks if the page is a single post. 

30.How do you create a custom WordPress widget? 
 
 php 
CopyEdit 
class My_Widget extends WP_Widget { 
    function __construct() { 
        parent::__construct('my_widget', __('My Widget')); 
    } 
    function widget($args, $instance) { 
        echo "Hello from my custom widget!"; 
    } 
} 
add_action('widgets_init', function() { 
    register_widget('My_Widget'); 
}); 
 
 

Here are the answers to your WordPress questions: 

 

31. How do you create a 301 redirect in WordPress? 

A 301 redirect permanently redirects an old URL to a new one. You can do this using: 

Method 1: Using a Plugin 



 

● Install and activate the Redirection plugin. 
● Go to Tools → Redirection and set up your redirect. 

Method 2: Editing .htaccess File 

Add the following code to your .htaccess file: 

Redirect 301 /old-page https://yourwebsite.com/new-page 
 

Method 3: Using functions.php 
function custom_redirect() { 
    if (is_page('old-page')) { 
        wp_redirect('https://yourwebsite.com/new-page', 301); 
        exit(); 
    } 
} 
add_action('template_redirect', 'custom_redirect'); 
 

 

32. What is wp_enqueue_script()? 

wp_enqueue_script() is a function used to properly load and manage JavaScript 
files in WordPress. 

Example Usage: 
function custom_scripts() { 
    wp_enqueue_script('my-script', get_template_directory_uri() . '/js/custom.js', 
array('jquery'), '1.0.0', true); 
} 
add_action('wp_enqueue_scripts', 'custom_scripts'); 
 

● The function ensures scripts are loaded only when needed and avoids 
conflicts. 

 

33. What is wp_head()? 

The wp_head() function is used to insert essential scripts, styles, and metadata into 
the <head> section of a WordPress theme. 

Usage in header.php file: 
<head> 
    <?php wp_head(); ?> 
</head> 



 

 

● It loads stylesheets, meta tags, and scripts added by WordPress and plugins. 

 

34. How do you schedule posts in WordPress? 

1. In the Post Editor, click on the "Publish" button dropdown. 
2. Select "Schedule" instead of "Publish Immediately." 
3. Set the desired date and time. 
4. Click "Schedule." 

 

35. How do you prevent spam in WordPress? 

● Use Akismet Anti-Spam Plugin 
● Enable reCAPTCHA on forms 
● Limit comments and enable moderation 
● Use a plugin like Antispam Bee 

 

36. What is a WordPress nonce? 

A nonce (Number Used Once) is a security token used to protect forms and URLs 
from CSRF attacks. 

Example Usage: 
<?php wp_nonce_field('my_action', 'my_nonce'); ?> 
 

To verify the nonce: 

if (!wp_verify_nonce($_POST['my_nonce'], 'my_action')) { 
    die('Security check failed'); 
} 
 

 

37. How do you add custom fields in WordPress? 

● Go to Post Editor → Screen Options → Enable Custom Fields. 
● Add a new field (name & value). 
● Retrieve it using PHP: 

<?php echo get_post_meta(get_the_ID(), 'custom_field_name', true); ?> 
 



 

 

38. How do you remove "Powered by WordPress" from the footer? 

Method 1: Using Theme Customizer 

● Go to Appearance → Customize → Footer. 

Method 2: Editing footer.php 

Locate and remove: 

<p>Powered by <a href="https://wordpress.org/">WordPress</a></p> 
 

 

39. What is lazy loading in WordPress? 

Lazy loading delays image loading until they are visible on the screen, improving 
website speed. 

How to Enable Lazy Loading? 

● WordPress has built-in lazy loading (WordPress 5.5+). 
● Use a plugin like Lazy Load by WP Rocket. 

 

40. How do you create a sticky post in WordPress? 

1. Edit a Post → Open Document Settings. 
2. Under Visibility, select "Stick to the top of the blog." 
3. Click Update. 

 

41. What are the best SEO plugins for WordPress? 

● Yoast SEO 
● Rank Math 
● All-in-One SEO Pack 
● SEOPress 

 

42. How do you create a multilingual WordPress website? 

● Use Polylang or WPML plugin. 
● Configure languages and add translations for posts/pages. 



 

 

43. What is the difference between do_action() and 
apply_filters()? 

● do_action() executes custom functions at a specific point. 
● apply_filters() modifies data before output. 

Example: 
do_action('custom_action'); 
apply_filters('custom_filter', $data); 
 

 

44. How do you migrate a WordPress site manually? 

1. Backup files and database using phpMyAdmin. 
2. Transfer files via FTP. 
3. Import the database on the new server. 
4. Update wp-config.php with new database details. 
5. Update URLs in phpMyAdmin (wp_options table). 

 

45. How do you backup a WordPress website? 

Method 1: Using a Plugin 

● Install UpdraftPlus or BackupBuddy. 
● Schedule automatic backups. 

Method 2: Manually Backup via cPanel 

● Download all files via FTP. 
● Export the database via phpMyAdmin. 

 

46. What is a multisite in WordPress? 

A multisite allows multiple websites to run on a single WordPress installation. 

How to Enable? 

Add this to wp-config.php: 

define('WP_ALLOW_MULTISITE', true); 
 



 

Then, go to Tools → Network Setup and configure it. 

 

47. How do you handle the white screen of death in WordPress? 
Increase memory limit in wp-config.php: 
 define('WP_MEMORY_LIMIT', '256M'); 

●  
● Disable plugins via FTP (/wp-content/plugins/). 
● Switch to a default theme (/wp-content/themes/). 

 

48. How do you limit login attempts in WordPress? 

● Install Limit Login Attempts Reloaded plugin. 
● Configure maximum login attempts. 

 

49. How do you use wp_mail() to send emails? 

Use wp_mail() to send emails via WordPress: 

$to = 'user@example.com'; 
$subject = 'Welcome!'; 
$message = 'Thank you for signing up!'; 
$headers = array('Content-Type: text/html; charset=UTF-8'); 
 
wp_mail($to, $subject, $message, $headers); 
 

If emails don’t work, install WP Mail SMTP plugin. 

 

50. What is XML-RPC in WordPress? 

XML-RPC is a protocol that allows remote communication with WordPress (e.g., 
mobile apps). 

Disable XML-RPC for security: 

add_filter('xmlrpc_enabled', '__return_false'); 
 



 

🔹 Security & Performance in WordPress 

51. How do you harden WordPress security? 

● Use HTTPS (SSL Certificate) 
● Change the default login URL (Use “WPS Hide Login” plugin) 
● Disable XML-RPC 
● Limit login attempts 
● Use Two-Factor Authentication (2FA) 

Disable file editing in wp-config.php: 
 define('DISALLOW_FILE_EDIT', true); 

●  
● Keep WordPress updated 

 

52. How do you prevent brute-force attacks on a WordPress site? 

● Install Wordfence or iThemes Security 
● Enable reCAPTCHA for login forms 

Add .htaccess protection: 
 <Files wp-login.php> 
order deny,allow 
Deny from all 
Allow from YOUR_IP 
</Files> 

●  

 

53. How do you increase the memory limit in WordPress? 

Add this to wp-config.php: 

define('WP_MEMORY_LIMIT', '512M'); 
 

 

54. How do you optimize the WordPress database? 

● Use WP-Optimize or WP-Sweep plugin 

Run SQL commands in phpMyAdmin: 
 OPTIMIZE TABLE wp_posts; 



 

●  

 

55. How do you reduce the number of database queries in WordPress? 

● Use wp_cache_get() and wp_cache_set() 

Implement transients: 
 set_transient('custom_query_cache', $query_results, 12 * HOUR_IN_SECONDS); 

●  

 

56. How do you implement object caching in WordPress? 

● Use Redis or Memcached 

Add wp_cache functions: 
 wp_cache_set('key', 'value'); 

●  

 

57. How do you lazy load images manually? 
<img src="image.jpg" loading="lazy" /> 
 

 

58. How do you minify CSS and JavaScript in WordPress? 

● Use Autoptimize or WP Rocket plugin 
● Manually minify using wp_enqueue_script() 

 

🔹 WordPress Hooks & Functions 

59. What is the difference between an action and a filter? 

● Actions (do_action()): Run at specific points but do not return data. 
● Filters (apply_filters()): Modify and return data. 

Example: 
add_action('init', function() { echo "Action Triggered!"; }); 



 

 
add_filter('the_content', function($content) { return $content . " - Modified"; }); 
 

 

60. How do you create a custom WordPress hook? 
// Define custom action 
do_action('custom_action'); 
 
// Add function to action 
add_action('custom_action', function() { echo "Custom Hook Triggered!"; }); 
 

 

61. What is wp_schedule_event() used for? 

Schedules tasks in WordPress cron jobs. 

if (!wp_next_scheduled('custom_cron_event')) { 
    wp_schedule_event(time(), 'hourly', 'custom_cron_event'); 
} 
 

 

62. How do you remove a WordPress action or filter? 
remove_action('wp_head', 'wp_generator'); 
remove_filter('the_content', 'wpautop'); 
 

 

63. How do you create a custom API endpoint in WordPress? 
add_action('rest_api_init', function() { 
    register_rest_route('custom/v1', '/data/', array( 
        'methods' => 'GET', 
        'callback' => 'custom_api_function', 
    )); 
}); 
 
function custom_api_function() { 
    return array('message' => 'Hello, API!'); 
} 
 

 

🔹 WordPress Theme Development 



 

64. How do you create a custom WordPress theme? 

● Create a folder in /wp-content/themes/ 
● Add style.css and index.php 

Register theme in style.css: 
 /* 
Theme Name: Custom Theme 
Author: Your Name 
*/ 

●  

 

65. How do you enqueue a custom stylesheet? 
function my_theme_styles() { 
    wp_enqueue_style('custom-style', get_stylesheet_uri()); 
} 
add_action('wp_enqueue_scripts', 'my_theme_styles'); 
 

 

66. How do you add a custom sidebar? 
function custom_sidebar() { 
    register_sidebar(array( 
        'name' => 'Custom Sidebar', 
        'id' => 'custom-sidebar', 
        'before_widget' => '<div>', 
        'after_widget' => '</div>', 
    )); 
} 
add_action('widgets_init', 'custom_sidebar'); 
 

 

67. How do you create a custom page template? 

● Create custom-template.php 

Add this at the top: 
 <?php 
/* Template Name: Custom Page */ 

●  
● Use it in Page Attributes → Template. 



 

 

🔹 Advanced Customization 

68. How do you create a Gutenberg block? 

1. Install @wordpress/scripts 

Register block in index.js: 
 wp.blocks.registerBlockType('custom/block', { 
    title: 'Custom Block', 
    edit: () => wp.element.createElement('p', {}, 'Hello from block!'), 
    save: () => wp.element.createElement('p', {}, 'Hello from block!') 
}); 

2.  

 

69. How do you modify the WordPress admin menu? 
function custom_admin_menu() { 
    add_menu_page('Custom Page', 'Custom Menu', 'manage_options', 'custom-slug', 
'custom_page_function'); 
} 
add_action('admin_menu', 'custom_admin_menu'); 
 

 

70. How do you add a meta box to posts? 
function custom_meta_box() { 
    add_meta_box('custom_id', 'Custom Meta Box', 'custom_meta_callback', 'post'); 
} 
add_action('add_meta_boxes', 'custom_meta_box'); 
 
function custom_meta_callback($post) { 
    echo '<input type="text" name="custom_field" />'; 
} 
 

 

71. How do you create a custom taxonomy? 
register_taxonomy('genre', 'post', array( 
    'label' => 'Genres', 
    'hierarchical' => true 
)); 
 



 

 

72. How do you add a settings page in WordPress? 
function custom_settings_page() { 
    add_options_page('Custom Settings', 'Custom Settings', 'manage_options', 
'custom-settings', 'custom_settings_html'); 
} 
add_action('admin_menu', 'custom_settings_page'); 
 

 

🔹 Final Advanced Topics 

73. How do you optimize WordPress for high traffic? 

● Use a CDN (Cloudflare) 
● Enable caching (Redis, WP Rocket) 
● Use a lightweight theme 

 

74. What is headless WordPress? 

Using WordPress as a backend API with frontend frameworks like React or Vue. 

 

75. How do you disable WordPress auto-updates? 
define('AUTOMATIC_UPDATER_DISABLED', true); 
 

 

76. How do you integrate React with WordPress? 

● Use the WordPress REST API 
● Install wp-react-plugin 

 

77. How do you debug WordPress errors? 

Enable debugging in wp-config.php: 

define('WP_DEBUG', true); 
 

 



 

78. What are transients in WordPress? 

Transients store temporary data. 

set_transient('cache_key', 'data', 60 * 60); 
 

Here are 22 more advanced WordPress interview questions (78-100) covering 
performance, security, APIs, headless WordPress, database optimization, and custom 
development. 

 

🔹 WordPress Performance & Optimization 

78. How do you optimize WordPress queries for high-performance 
websites? 

● Use WP_Query efficiently with fields => ids to fetch only necessary data. 

Cache queries using transients: 
 $posts = get_transient('cached_query'); 

if (!$posts) { 

    $query = new WP_Query(['posts_per_page' => 5]); 

    $posts = $query->posts; 

    set_transient('cached_query', $posts, 12 * HOUR_IN_SECONDS); 

} 

●  

 

79. How do you improve TTFB (Time to First Byte) in WordPress? 

● Enable full-page caching with WP Rocket or Nginx FastCGI Cache 
● Use Redis or Memcached for object caching 
● Optimize database queries with indexing 
● Enable HTTP/2 and GZIP compression 

 

80. How do you remove render-blocking JavaScript and CSS in 
WordPress? 



 

● Use the Autoptimize plugin to defer JavaScript and optimize CSS 

Manually enqueue scripts with defer: 
 function add_defer_attribute($tag, $handle) { 

    if (!is_admin()) { 

        $tag = str_replace(' src', ' defer="defer" src', $tag); 

    } 

    return $tag; 

} 

add_filter('script_loader_tag', 'add_defer_attribute', 10, 2); 

●  

 

🔹 WordPress Security & Hardening 

81. How do you secure WordPress file permissions? 

● Set wp-config.php permissions to 400 or 440 
● Set wp-content/uploads to 755 

Disable directory listing via .htaccess: 
 Options -Indexes 

●  

 

82. How do you disable PHP execution in the uploads directory? 

Create an .htaccess file in /wp-content/uploads/: 
 <FilesMatch "\.(php|php\.)"> 

Order Deny,Allow 

Deny from all 

</FilesMatch> 

●  

 



 

83. How do you prevent WordPress user enumeration attacks? 

Add this to .htaccess: 

RewriteCond %{QUERY_STRING} author=\d 

RewriteRule ^ - [F] 

 

 

84. How do you disable WordPress REST API for non-authenticated 
users? 

function disable_rest_api($access) { 

    if (!is_user_logged_in()) { 

        return new WP_Error('rest_disabled', 'REST API restricted', ['status' => 403]); 

    } 

    return $access; 

} 

add_filter('rest_authentication_errors', 'disable_rest_api'); 

 

 

🔹 WordPress Database Optimization 

85. How do you reduce database bloat in WordPress? 

Delete post revisions: 
 DELETE FROM wp_posts WHERE post_type = 'revision'; 

●  

Limit post revisions in wp-config.php: 
 define('WP_POST_REVISIONS', 5); 

●  

 



 

86. How do you delete transients from the WordPress database? 

global $wpdb; 

$wpdb->query("DELETE FROM $wpdb->options WHERE option_name LIKE 
'_transient_%'"); 

 

 

87. How do you remove orphaned metadata from the database? 

DELETE FROM wp_postmeta WHERE meta_key NOT IN (SELECT DISTINCT meta_key 
FROM wp_posts); 

 

 

🔹 WordPress APIs & Headless WordPress 

88. What is the WordPress REST API, and how do you fetch posts from 
it? 

The WordPress REST API allows external applications to interact with WordPress. 

Fetch posts using JavaScript: 

fetch('https://example.com/wp-json/wp/v2/posts') 

  .then(response => response.json()) 

  .then(posts => console.log(posts)); 

 

 

89. How do you register a custom REST API endpoint? 

add_action('rest_api_init', function() { 

    register_rest_route('custom/v1', '/data/', array( 

        'methods' => 'GET', 

        'callback' => 'custom_api_callback', 



 

    )); 

}); 

 

function custom_api_callback() { 

    return rest_ensure_response(['message' => 'Hello, API!']); 

} 

 

 

90. What is GraphQL, and how do you integrate it with WordPress? 

● GraphQL allows fetching data using flexible queries. 
● Install WPGraphQL plugin. 
● Example query: 

{ 

  posts { 

    nodes { 

      title 

      content 

    } 

  } 

} 

 

 

🔹 Advanced Custom Development 

91. How do you create a custom user role in WordPress? 

function add_custom_role() { 

    add_role('custom_editor', 'Custom Editor', array('read' => true, 'edit_posts' => 
true)); 



 

} 

add_action('init', 'add_custom_role'); 

 

 

92. How do you remove the admin bar for non-admin users? 

if (!current_user_can('administrator')) { 

    add_filter('show_admin_bar', '__return_false'); 

} 

 

 

93. How do you create a shortcode in WordPress? 

function custom_shortcode() { 

    return "Hello, this is a custom shortcode!"; 

} 

add_shortcode('custom_text', 'custom_shortcode'); 

 

Usage: [custom_text] 

 

94. How do you override a parent theme function in a child theme? 

● Copy the function to functions.php of the child theme. 
● Use remove_action() or remove_filter() to override it. 

 

95. How do you create a custom Gutenberg block? 

1. Install @wordpress/scripts 

Register block in index.js: 
 wp.blocks.registerBlockType('custom/block', { 



 

    title: 'Custom Block', 

    edit: () => wp.element.createElement('p', {}, 'Hello from block!'), 

    save: () => wp.element.createElement('p', {}, 'Hello from block!') 

}); 

2.  

Build with npm run build and register in PHP: 
 function custom_block_assets() { 

    wp_enqueue_script('custom-block', get_template_directory_uri() . '/block.js', 
array('wp-blocks')); 

} 

add_action('enqueue_block_editor_assets', 'custom_block_assets'); 

3.  

 

🔹 Advanced WordPress Optimization & Debugging 

96. How do you debug a slow WordPress website? 

● Enable Query Monitor plugin 

Check PHP error logs in wp-config.php: 
 define('WP_DEBUG', true); 

define('WP_DEBUG_LOG', true); 

●  
● Use New Relic for performance monitoring 

 

97. How do you disable WordPress auto-updates? 

define('AUTOMATIC_UPDATER_DISABLED', true); 

 

 

98. How do you implement infinite scroll in WordPress? 



 

● Use wp_ajax_nopriv_{action} for AJAX requests 
● Fetch next posts using JavaScript 

 

99. How do you handle WordPress downtime? 

● Enable a staging environment 
● Use a fallback static HTML version 
● Implement server-level caching (e.g., Varnish, Redis) 

 

100. What are the best practices for WordPress scalability? 

● Use horizontal scaling (multiple servers) 
● Implement object caching with Redis 
● Use a CDN (Cloudflare, AWS CloudFront) 
● Optimize database queries & indexes 
● Enable server-side caching (Nginx, Varnish) 
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